zjlseo

关于SEO/付费搜索的一些经验和想法

z-blog插件升级显示PHP版本过低无法升级及升级PHP版本过后导致显示数据库连接失败无法访问网站

       在升级z-blog博客系统版本的z-blog免费插件的时候出现了一个问题,系统版本可以正常升级,但是升级其中的一个插件的时候却显示PHP版本太低无法升级,用的阿里云,然后上了阿里云(用的是阿里云虚拟主机)看了下之前选择的PHP版本,没想到是最低版本PHP5.2, 实在低的不能再低了,于是就想升级下版本的升级下插件,就直接在网页版本虚拟主机控制后台里面的高级环境设置里面直接把PHP5.2升级到了支持的最高版本PHP7.2,然后保存了设置,但是等我回到www.zjlseo.com主页的时候却提示打开错误,提示无法与数据库进行连接,导致网站不能访问,于是就找下原因解决网站访问的问题。

      1、可以直接在虚拟主机控制后台直接升级,没有问题,但是会在升级的时候提醒升级到最新版本密码保护不是原来的16位而是41位,这个要注意。

      2、选择最新版本的PHP版本过后,要去虚拟主机网页面板的站点信息处修改数据库密码,原先的老PHP版本默认的是16位,数据库重置密码的时候选择41位(必须要设定41位,不能16位)。

      3、数据库重置密码过去,用FTP远程登录,按htdocs > zb_users > c_option.php, 修改下数据库密码,下图:z-blog插件升级显示PHP版本过低无法升级及升级PHP版本过后导致显示数据库连接失败无法访问网站保存就可以了,重新打开网站就可以访问了。不需要修改其它地方。



发表评论:

◎欢迎参与讨论,请在这里发表您的看法、交流您的观点。

Powered By Z-BlogPHP 1.6.0 Valyria

粤ICP备16066897号-1。版权所有,转载请注明出处!